const regex = /(?s)<a(?!.*<a).+<\/a>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<a(?!.*<a).+<\\\/a>', '')
const str = `<div id="breadcrumbs">
<a href="/">Home</a>
<a href="/suppliers">Suppliers</a>
<button>This One i needed</button>
<span class="currentpage">Amrapali</span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}