import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<a(?!.*<a).+<\\/a>";
final String string = "<div id=\"breadcrumbs\">\n"
+ " <a href=\"/\">Home</a>\n"
+ " <a href=\"/suppliers\">Suppliers</a>\n"
+ " <button>This One i needed</button> \n"
+ " <span class=\"currentpage\">Amrapali</span>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}