using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<a(?!.*<a).+<\/a>";
string input = @"<div id=""breadcrumbs"">
<a href=""/"">Home</a>
<a href=""/suppliers"">Suppliers</a>
<button>This One i needed</button>
<span class=""currentpage"">Amrapali</span>
</div>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}