#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?>(?<=class=")|(?!^)\G)(?>\b([-\w]++)\b(?=[^"]*?\s\1[\s"])\s+|[-\w]+\s+\K)"
Local $sString = "<li class="a-b a-c 3 2 1 is it this or this is it or it is this 1 2 3 a-c a-b">"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)