import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>(?<=class=\")|(?!^)\\G)(?>\\b([-\\w]++)\\b(?=[^\"]*?\\s\\1[\\s\"])\\s+|[-\\w]+\\s+\\K)";
final String string = "<li class=\"a-b a-c 3 2 1 is it this or this is it or it is this 1 2 3 a-c a-b\">";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}