const regex = /(?>(?<=class=")|(?!^)\G)(?>\b([-\w]++)\b(?=[^"]*?\s\1[\s"])\s+|[-\w]+\s+\K)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?>(?<=class=")|(?!^)\\G)(?>\\b([-\\w]++)\\b(?=[^"]*?\\s\\1[\\s"])\\s+|[-\\w]+\\s+\\K)', 'g')
const str = `<li class="a-b a-c 3 2 1 is it this or this is it or it is this 1 2 3 a-c a-b">`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);