use strict;
my $str = '<li class="a-b a-c 3 2 1 is it this or this is it or it is this 1 2 3 a-c a-b">';
my $regex = qr/(?>(?<=class=")|(?!^)\G)(?>\b([-\w]++)\b(?=[^"]*?\s\1[\s"])\s+|[-\w]+\s+\K)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";