# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?>(?<=class=\")|(?!^)\G)(?>\b([-\w]++)\b(?=[^\"]*?\s\1[\s\"])\s+|[-\w]+\s+\K)"
test_str = "<li class=\"a-b a-c 3 2 1 is it this or this is it or it is this 1 2 3 a-c a-b\">"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.