$re = '/(?>(?<=class=")|(?!^)\G)(?>\b([-\w]++)\b(?=[^"]*?\s\1[\s"])\s+|[-\w]+\s+\K)/';
$str = '<li class="a-b a-c 3 2 1 is it this or this is it or it is this 1 2 3 a-c a-b">';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;