using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?>(?<=class="")|(?!^)\G)(?>\b([-\w]++)\b(?=[^""]*?\s\1[\s""])\s+|[-\w]+\s+\K)";
string substitution = @"";
string input = @"<li class=""a-b a-c 3 2 1 is it this or this is it or it is this 1 2 3 a-c a-b"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}