# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:<a href="|\G)\S*\K (?=[^">]*")/%20/g;t' <<< "<a href=\"file with spaces.mp3\">file with spaces.mp3</a>"