const regex = /(?:<a href="|\G)\S*\K (?=[^">]*")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<a href="|\\G)\\S*\\K (?=[^">]*")', 'g')
const str = `<a href="file with spaces.mp3">file with spaces.mp3</a>`;
const subst = `%20`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);