import Foundation
let pattern = #"(?:<a href="|\G)\S*\K (?=[^">]*")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<a href="file with spaces.mp3">file with spaces.mp3</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"%20"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)