use strict;
my $str = '<a href="file with spaces.mp3">file with spaces.mp3</a>';
my $regex = qr/(?:<a href="|\G)\S*\K (?=[^">]*")/p;
my $subst = '%20';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";