#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:<a href="|\G)\S*\K (?=[^">]*")"
Local $sString = "<a href="file with spaces.mp3">file with spaces.mp3</a>"
Local $sSubst = "%20"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)