using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<a href=""|\G)\S*\K (?=[^"">]*"")";
string substitution = @"%20";
string input = @"<a href=""file with spaces.mp3"">file with spaces.mp3</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}