# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(([^,\n]*,){4}[^,\n]*).*/\1/gm;t' <<< "movie/spiderman,genre/action,movie:marvel
movie/kingsman,genre/action
movie/spiderman,genre/action,movie:marvel,movie:dfjkl,movie:fskj,movie:aa,movie:mdkk"