$re = '/^(([^,\n]*,){4}[^,\n]*).*/m';
$str = 'movie/spiderman,genre/action,movie:marvel
movie/kingsman,genre/action
movie/spiderman,genre/action,movie:marvel,movie:dfjkl,movie:fskj,movie:aa,movie:mdkk';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;