const regex = /^(([^,\n]*,){4}[^,\n]*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([^,\\n]*,){4}[^,\\n]*).*', 'gm')
const str = `movie/spiderman,genre/action,movie:marvel
movie/kingsman,genre/action
movie/spiderman,genre/action,movie:marvel,movie:dfjkl,movie:fskj,movie:aa,movie:mdkk`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);