using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([^,\n]*,){4}[^,\n]*).*";
string substitution = @"\1";
string input = @"movie/spiderman,genre/action,movie:marvel
movie/kingsman,genre/action
movie/spiderman,genre/action,movie:marvel,movie:dfjkl,movie:fskj,movie:aa,movie:mdkk";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}