#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(([^,\n]*,){4}[^,\n]*).*"
Local $sString = "movie/spiderman,genre/action,movie:marvel" & @CRLF & _
"movie/kingsman,genre/action" & @CRLF & _
"movie/spiderman,genre/action,movie:marvel,movie:dfjkl,movie:fskj,movie:aa,movie:mdkk"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)