package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([^,\n]*,){4}[^,\n]*).*`)
var str = `movie/spiderman,genre/action,movie:marvel
movie/kingsman,genre/action
movie/spiderman,genre/action,movie:marvel,movie:dfjkl,movie:fskj,movie:aa,movie:mdkk`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}