#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b0*(?:(?:[12]\d|[3-9])\d{3,}|2(?:0(?:1[89]|[2-9]\d)|[1-9]\d{2}))(?=-\d{2}-\d{2} \d{2}:\d{2}:\d{2})"
Local $sString = "EMISSAO="2016-04-18 00:00:00"" & @CRLF & _
"EMISSAO="65321-04-18 00:00:00"" & @CRLF & _
"EMISSAO="2018-04-18 00:00:00"" & @CRLF & _
"EMISSAO="2017-04-18 00:00:00"" & @CRLF & _
"EMISSAO="20170-04-18 00:00:00"" & @CRLF & _
"EMISSAO="1999-04-18 00:00:00"" & @CRLF & _
"EMISSAO="19991-04-18 00:00:00"" & @CRLF & _
"EMISSAO="2001-04-18 00:00:00"" & @CRLF & _
"EMISSAO="12001-04-18 00:00:00"" & @CRLF & _
"EMISSAO="22016-04-18 00:00:00""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")