import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0*(?:(?:[12]\\d|[3-9])\\d{3,}|2(?:0(?:1[89]|[2-9]\\d)|[1-9]\\d{2}))(?=-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2})";
final String string = "EMISSAO=\"2016-04-18 00:00:00\"\n"
+ "EMISSAO=\"65321-04-18 00:00:00\"\n"
+ "EMISSAO=\"2018-04-18 00:00:00\"\n"
+ "EMISSAO=\"2017-04-18 00:00:00\"\n"
+ "EMISSAO=\"20170-04-18 00:00:00\"\n"
+ "EMISSAO=\"1999-04-18 00:00:00\"\n"
+ "EMISSAO=\"19991-04-18 00:00:00\"\n"
+ "EMISSAO=\"2001-04-18 00:00:00\"\n"
+ "EMISSAO=\"12001-04-18 00:00:00\"\n"
+ "EMISSAO=\"22016-04-18 00:00:00\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}