import Foundation
let pattern = #"\b0*(?:(?:[12]\d|[3-9])\d{3,}|2(?:0(?:1[89]|[2-9]\d)|[1-9]\d{2}))(?=-\d{2}-\d{2} \d{2}:\d{2}:\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
EMISSAO="2016-04-18 00:00:00"
EMISSAO="65321-04-18 00:00:00"
EMISSAO="2018-04-18 00:00:00"
EMISSAO="2017-04-18 00:00:00"
EMISSAO="20170-04-18 00:00:00"
EMISSAO="1999-04-18 00:00:00"
EMISSAO="19991-04-18 00:00:00"
EMISSAO="2001-04-18 00:00:00"
EMISSAO="12001-04-18 00:00:00"
EMISSAO="22016-04-18 00:00:00"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)