const regex = /\b0*(?:(?:[12]\d|[3-9])\d{3,}|2(?:0(?:1[89]|[2-9]\d)|[1-9]\d{2}))(?=-\d{2}-\d{2} \d{2}:\d{2}:\d{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0*(?:(?:[12]\\d|[3-9])\\d{3,}|2(?:0(?:1[89]|[2-9]\\d)|[1-9]\\d{2}))(?=-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2})', 'g')
const str = `EMISSAO="2016-04-18 00:00:00"
EMISSAO="65321-04-18 00:00:00"
EMISSAO="2018-04-18 00:00:00"
EMISSAO="2017-04-18 00:00:00"
EMISSAO="20170-04-18 00:00:00"
EMISSAO="1999-04-18 00:00:00"
EMISSAO="19991-04-18 00:00:00"
EMISSAO="2001-04-18 00:00:00"
EMISSAO="12001-04-18 00:00:00"
EMISSAO="22016-04-18 00:00:00"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}