$re = '/\b0*(?:(?:[12]\d|[3-9])\d{3,}|2(?:0(?:1[89]|[2-9]\d)|[1-9]\d{2}))(?=-\d{2}-\d{2} \d{2}:\d{2}:\d{2})/';
$str = 'EMISSAO="2016-04-18 00:00:00"
EMISSAO="65321-04-18 00:00:00"
EMISSAO="2018-04-18 00:00:00"
EMISSAO="2017-04-18 00:00:00"
EMISSAO="20170-04-18 00:00:00"
EMISSAO="1999-04-18 00:00:00"
EMISSAO="19991-04-18 00:00:00"
EMISSAO="2001-04-18 00:00:00"
EMISSAO="12001-04-18 00:00:00"
EMISSAO="22016-04-18 00:00:00"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);