use strict;
my $str = 'EMISSAO="2016-04-18 00:00:00"
EMISSAO="65321-04-18 00:00:00"
EMISSAO="2018-04-18 00:00:00"
EMISSAO="2017-04-18 00:00:00"
EMISSAO="20170-04-18 00:00:00"
EMISSAO="1999-04-18 00:00:00"
EMISSAO="19991-04-18 00:00:00"
EMISSAO="2001-04-18 00:00:00"
EMISSAO="12001-04-18 00:00:00"
EMISSAO="22016-04-18 00:00:00"';
my $regex = qr/\b0*(?:(?:[12]\d|[3-9])\d{3,}|2(?:0(?:1[89]|[2-9]\d)|[1-9]\d{2}))(?=-\d{2}-\d{2} \d{2}:\d{2}:\d{2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}