import re
regex = re.compile(r"\b0*(?:(?:[12]\d|[3-9])\d{3,}|2(?:0(?:1[89]|[2-9]\d)|[1-9]\d{2}))(?=-\d{2}-\d{2} \d{2}:\d{2}:\d{2})")
test_str = ("EMISSAO=\"2016-04-18 00:00:00\"\n"
"EMISSAO=\"65321-04-18 00:00:00\"\n"
"EMISSAO=\"2018-04-18 00:00:00\"\n"
"EMISSAO=\"2017-04-18 00:00:00\"\n"
"EMISSAO=\"20170-04-18 00:00:00\"\n"
"EMISSAO=\"1999-04-18 00:00:00\"\n"
"EMISSAO=\"19991-04-18 00:00:00\"\n"
"EMISSAO=\"2001-04-18 00:00:00\"\n"
"EMISSAO=\"12001-04-18 00:00:00\"\n"
"EMISSAO=\"22016-04-18 00:00:00\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")