package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)
^
(?=.{1,30}$)
(?:
[a-z.,'\-\h]{2}%
|
[a-z.,'\-\h]
)+
$`)
var str = `asdSRVGD
as%
assvd-,'
asdbSERF,%
### Incorrect %
a%
%
### Length >= 30
abcdefghijklmnopqrstuvwxyzABCDE
### Invalid characters
1abcd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}