const regex = /(?i)
^
(?=.{1,30}$)
(?:
[a-z.,'\-\h]{2}%
|
[a-z.,'\-\h]
)+
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)
^
(?=.{1,30}$)
(?:
[a-z.,\'\\-\\h]{2}%
|
[a-z.,\'\\-\\h]
)+
$', 'gm')
const str = `asdSRVGD
as%
assvd-,'
asdbSERF,%
### Incorrect %
a%
%
### Length >= 30
abcdefghijklmnopqrstuvwxyzABCDE
### Invalid characters
1abcd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}