re = /(?i)
^
(?=.{1,30}$)
(?:
[a-z.,'\-\h]{2}%
|
[a-z.,'\-\h]
)+
$/mx
str = 'asdSRVGD
as%
assvd-,\'
asdbSERF,%
### Incorrect %
a%
%
### Length >= 30
abcdefghijklmnopqrstuvwxyzABCDE
### Invalid characters
1abcd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end