$re = '/(?i)
^
(?=.{1,30}$)
(?:
[a-z.,\'\-\h]{2}%
|
[a-z.,\'\-\h]
)+
$/mx';
$str = 'asdSRVGD
as%
assvd-,\'
asdbSERF,%
### Incorrect %
a%
%
### Length >= 30
abcdefghijklmnopqrstuvwxyzABCDE
### Invalid characters
1abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);