// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?i)
^
(?=.{1,30}$)
(?:
[a-z.,'\-\h]{2}%
|
[a-z.,'\-\h]
)+
$").unwrap();
let string = "asdSRVGD
as%
assvd-,'
asdbSERF,%
### Incorrect %
a%
%
### Length >= 30
abcdefghijklmnopqrstuvwxyzABCDE
### Invalid characters
1abcd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}