import Foundation
let pattern = #"""
(?i)
^
(?=.{1,30}$)
(?:
[a-z.,'\-\h]{2}%
|
[a-z.,'\-\h]
)+
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ####"""
asdSRVGD
as%
assvd-,'
asdbSERF,%
### Incorrect %
a%
%
### Length >= 30
abcdefghijklmnopqrstuvwxyzABCDE
### Invalid characters
1abcd
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)