import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\n"
+ "^\n"
+ "(?=.{1,30}$)\n"
+ "(?:\n"
+ " [a-z.,'\\-\\h]{2}%\n"
+ "|\n"
+ " [a-z.,'\\-\\h]\n"
+ ")+\n"
+ "$";
final String string = "asdSRVGD\n"
+ "as%\n"
+ "assvd-,'\n"
+ "asdbSERF,%\n\n"
+ "### Incorrect %\n"
+ "a%\n"
+ "%\n\n"
+ "### Length >= 30\n"
+ "abcdefghijklmnopqrstuvwxyzABCDE\n\n"
+ "### Invalid characters\n"
+ "1abcd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}