import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "role:(?:\\(\\K[^()]+(?=\\))|'\\K[^']+(?='))";
final String string = "\"languages:(ruby AND python) role:(software engineer or data scientist)\"\n"
+ "\"role:(software engineer or data scientist) languages:(ruby AND python)\"\n"
+ "\"languages:'python' role:'software engineer'\"\n"
+ "\"languages:(ruby AND python)role:(software engineer or data scientist)\"\n"
+ "\"languages:'python'role:'software engineer'\"\n"
+ "\"languages:'python'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}