import Foundation
let pattern = #"role:(?:\(\K[^()]+(?=\))|'\K[^']+(?='))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"languages:(ruby AND python) role:(software engineer or data scientist)"
"role:(software engineer or data scientist) languages:(ruby AND python)"
"languages:'python' role:'software engineer'"
"languages:(ruby AND python)role:(software engineer or data scientist)"
"languages:'python'role:'software engineer'"
"languages:'python'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)