# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|target)(?:(?!luke|(?:end)?target).)*\Kluke(?=(?:(?!(?:end)?target).)*endtarget)/<SOME>/gm;t' <<< "targethelloluketestlukeluketestluktestingendtarget
sourcehelloluketestlukeluketestluktestingendsource"