import re
regex = re.compile(r"(?:\G(?!\A)|target)(?:(?!luke|(?:end)?target).)*\Kluke(?=(?:(?!(?:end)?target).)*endtarget)", flags=re.MULTILINE)
test_str = ("targethelloluketestlukeluketestluktestingendtarget\n"
"sourcehelloluketestlukeluketestluktestingendsource")
subst = "<SOME>"
result = regex.sub(subst, test_str)
if result:
print(result)