const regex = /(?:\G(?!\A)|target)(?:(?!luke|(?:end)?target).)*\Kluke(?=(?:(?!(?:end)?target).)*endtarget)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|target)(?:(?!luke|(?:end)?target).)*\\Kluke(?=(?:(?!(?:end)?target).)*endtarget)', 'gm')
const str = `targethelloluketestlukeluketestluktestingendtarget
sourcehelloluketestlukeluketestluktestingendsource`;
const subst = `<SOME>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);