re = /(?:\G(?!\A)|target)(?:(?!luke|(?:end)?target).)*\Kluke(?=(?:(?!(?:end)?target).)*endtarget)/m
str = 'targethelloluketestlukeluketestluktestingendtarget
sourcehelloluketestlukeluketestluktestingendsource'
subst = '<SOME>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result