$re = '/(?:\G(?!\A)|target)(?:(?!luke|(?:end)?target).)*\Kluke(?=(?:(?!(?:end)?target).)*endtarget)/m';
$str = 'targethelloluketestlukeluketestluktestingendtarget
sourcehelloluketestlukeluketestluktestingendsource';
$subst = "<SOME>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;