use strict;
my $str = 'sometext {% {{ var1 }} middletext {{ var2 }} %} moretext {{ varx }} {% {{ var3 }} %}';
my $regex = qr/{{\s*(\w*)\s*}}(?=[^%]*%})/mp;
my $subst = '\\$$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";