import re
regex = re.compile(r"{{\s*(\w*)\s*}}(?=[^%]*%})", flags=re.MULTILINE)
test_str = "sometext {% {{ var1 }} middletext {{ var2 }} %} moretext {{ varx }} {% {{ var3 }} %}"
subst = "\\$$1"
result = regex.sub(subst, test_str)
if result:
print(result)