$re = '/{{\s*(\w*)\s*}}(?=[^%]*%})/m';
$str = 'sometext {% {{ var1 }} middletext {{ var2 }} %} moretext {{ varx }} {% {{ var3 }} %}';
$subst = "\$$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;