#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z0-9_\-]+(,?[a-zA-Z0-9_\-]+))*$"
Local $sString = "These should match:" & @CRLF & _
"host_one,host_two,host_three" & @CRLF & _
"hostone" & @CRLF & _
"env_qa" & @CRLF & _
"env-qa,env-qa,env-qa" & @CRLF & _
"1as-asd,asd1,awdf_adfw,1dasd-asda_asd" & @CRLF & _
"" & @CRLF & _
"Everything else should not match" & @CRLF & _
",env_qa" & @CRLF & _
"env-qa,env-qa,env-qa," & @CRLF & _
"$%5" & @CRLF & _
"," & @CRLF & _
",," & @CRLF & _
" ," & @CRLF & _
" , " & @CRLF & _
" , " & @CRLF & _
", " & @CRLF & _
"asdf," & @CRLF & _
"$" & @CRLF & _
"$%5" & @CRLF & _
"," & @CRLF & _
",asdf" & @CRLF & _
""asdf, "" & @CRLF & _
"asdf," & @CRLF & _
"" , "" & @CRLF & _
"";"" & @CRLF & _
"1as-asd,,asd1,awdf_adfw,1dasd-asda_asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")