using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9_\-]+(,?[a-zA-Z0-9_\-]+))*$";
string input = @"These should match:
host_one,host_two,host_three
hostone
env_qa
env-qa,env-qa,env-qa
1as-asd,asd1,awdf_adfw,1dasd-asda_asd
Everything else should not match
,env_qa
env-qa,env-qa,env-qa,
$%5
,
,,
,
,
,
,
asdf,
$
$%5
,
,asdf
""asdf, ""
asdf,
"" , ""
"";""
1as-asd,,asd1,awdf_adfw,1dasd-asda_asd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}