import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9_\\-]+(,?[a-zA-Z0-9_\\-]+))*$";
final String string = "These should match:\n"
+ "host_one,host_two,host_three\n"
+ "hostone\n"
+ "env_qa\n"
+ "env-qa,env-qa,env-qa\n"
+ "1as-asd,asd1,awdf_adfw,1dasd-asda_asd\n\n"
+ "Everything else should not match\n"
+ ",env_qa\n"
+ "env-qa,env-qa,env-qa,\n"
+ "$%5\n"
+ ",\n"
+ ",,\n"
+ " ,\n"
+ " , \n"
+ " , \n"
+ ", \n"
+ "asdf,\n"
+ "$\n"
+ "$%5\n"
+ ",\n"
+ ",asdf\n"
+ "\"asdf, \"\n"
+ "asdf,\n"
+ "\" , \"\n"
+ "\";\"\n"
+ "1as-asd,,asd1,awdf_adfw,1dasd-asda_asd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}