$re = '/^([a-zA-Z0-9_\-]+(,?[a-zA-Z0-9_\-]+))*$/m';
$str = 'These should match:
host_one,host_two,host_three
hostone
env_qa
env-qa,env-qa,env-qa
1as-asd,asd1,awdf_adfw,1dasd-asda_asd
Everything else should not match
,env_qa
env-qa,env-qa,env-qa,
$%5
,
,,
,
,
,
,
asdf,
$
$%5
,
,asdf
"asdf, "
asdf,
" , "
";"
1as-asd,,asd1,awdf_adfw,1dasd-asda_asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);